Zoom Games - zombie survival chapter 5 is under maintenance due to season 7 – Incident details

Try not to fall 2 under maintenance

zombie survival chapter 5 is under maintenance due to season 7

Resolved
Under maintenance
Started 12 months agoLasted 6 days

Affected

roblox games

Under maintenance from 5:16 PM to 4:31 PM

zombie survival

Under maintenance from 5:16 PM to 4:31 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Season og is out but the portal is only up until may 4th then season 7 chapter 5 will be released

  • Investigating
    Investigating
    We are currently investigating this incident.