Zoom Games - zombie survival season v5.50 – Incident details

zombie survival season v5.50

Resolved
Under maintenance
Started 11 months agoLasted about 1 hour

Affected

roblox games

Under maintenance from 11:03 AM to 11:52 AM

zombie survival

Under maintenance from 11:03 AM to 11:52 AM

Updates
  • Resolved
    Resolved

    zombie survival v5.50 is out now!

  • Investigating
    Investigating

    zombie survival is under maintenance during this time!