Zoom Games - Game is late to update cause roblox down!!! – Incident details
Report an issue
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Try not to fall 2 under maintenance
Game is late to update cause roblox down!!!
Resolved
Under maintenance
Started 29 days ago
Lasted about 1 hour
Affected
roblox games
Under maintenance from 8:05 PM to 8:52 PM
Clicker simulator
Under maintenance from 8:05 PM to 8:52 PM
Updates
Resolved
March 21, 2025 at 8:52 PM
Resolved
March 21, 2025 at 8:52 PM
Game update out now!!
Investigating
March 21, 2025 at 8:05 PM
Investigating
March 21, 2025 at 8:05 PM
We are currently investigating this incident.