Zoom Games - Realistic donations mobile issues!!! – Incident details

Try not to fall 2 under maintenance

Realistic donations mobile issues!!!

Resolved
Degraded performance
Started 2 months agoLasted 19 days

Affected

roblox games

Degraded performance from 7:10 PM to 5:04 PM

Realistic donations

Degraded performance from 7:10 PM to 5:04 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Realistic donations is having a few mobile issues!!!