Zoom Games - Realistic donations down!!! – Incident details

Try not to fall 2 under maintenance

Realistic donations down!!!

Resolved
Major outage
Started 2 months agoLasted 1 day

Affected

roblox games

Major outage from 8:21 AM to 7:08 PM

Realistic donations

Major outage from 8:21 AM to 7:08 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Realistic donations is having downtime while we update the game to the latest version.